Message Boards Message Boards

The DhO Itself

Cannot Save Uploaded Profile Photo in Account Settings

Toggle
To whom it may concern:

For a couple of weeks I've been trying to change my profile photo. I've checked the size of the photos I've tried, and they appear to upload, but when I try to save them, then I receive an error message that says, "Account settings are temporarily unavailable." I've tried a number of times over several weeks. Could this apparent system error be the one supposedly temporary thing in reality that is actually permanent?

Thanks in advance for some help,

Jenny

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
9/30/14 2:24 PM as a reply to Jenny.
Hi Jenny,

If you mail me the picture you are trying to use at simon@theoak.se I can check what is going wrong.

Simon

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
9/30/14 2:33 PM as a reply to Jenny.
Actually never mind, I've managed to reproduce the problem, I'm looking into it.

Simon

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
9/30/14 3:11 PM as a reply to Jenny.
Hi, I had the same problem. I think the filesize was too big; when I saved it as a jpg it worked.

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
9/30/14 3:26 PM as a reply to Jenny.
This is apparently a known (and fixed) Liferay bug, however getting it fixed will take a while as there is currently no release available with the fix.

There are some possible workarounds, slightly different image dimensions can help, or switching to a different browser - chrome triggers the bug for me while firefox works.

You can also send the image you want to my email address above and I'll add it to your profile.

Simon

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
9/30/14 3:32 PM as a reply to Dada Kind.
Droll Dedekind:
Hi, I had the same problem. I think the filesize was too big; when I saved it as a jpg it worked.

It's not just a filesize issue unfortunately, here's the liferay bug for reference:
https://issues.liferay.com/browse/LPS-39618

Simon

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
10/1/14 12:12 AM as a reply to Simon Ekstrand.
Simon, I can not message you. your name does not come up as a recipient....same with Tom Tom and others.
Could you take a look?

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
10/1/14 1:08 AM as a reply to Dream Walker.
Yeah, same here, Simon. Before I posted here, I tried to message you, but your name was not in the menu, oddly.

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
10/1/14 1:59 AM as a reply to Jenny.
The messaging portlett seems to only include the first 10 matches for a name which does make it sort of hard if the person you're searching for is not in that match list. It also seems to use a second word in the search box (ie. last name) as a completely new search term which isn't terribly helpful.

I've cleaned out a bunch of test simon accounts now so that my account is included in the list when searching for simon in the recipients field - so messaging me should work now!

Regarding Tom Tom the issue is pretty much the same, however there is a workaround that can be used atleast as a temporary measure.
If you click on the name of a poster (the one right under their picture in the left hand column), it takes you to their profile. A profile url looks something like: http://www.dharmaoverground.org/web/t-om/home (for tom tom). The t-om thing there is their chosen DhO Screen Name, that screen name can be used with the messaging portlett. In other words, enter t-om in the recipients field and you should get a direct hit for Tom Tom.

Hope that wasn't to confusing.

Simon

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
10/8/14 5:39 PM as a reply to Simon Ekstrand.
I switched to IE and the photo upload problem went away. I was using Chrome before.

RE: Cannot Save Uploaded Profile Photo in Account Settings
Answer
10/8/14 5:42 PM as a reply to Jenny.
This bothered me too. I used the newest version of Firefox a few days ago and I was able to upload my picture just fine.